Access Restriction Bypass Affecting org.apache.ozone:ozone-common Open this link in a new tab package, versions [,1.2.0)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

How to fix?

Upgrade org.apache.ozone:ozone-common to version 1.2.0 or higher.

Overview

Affected versions of this package are vulnerable to Access Restriction Bypass. Initially generated block tokens are persisted to the metadata database and can be retrieved with authenticated users with permission to the key. Authenticated users may use them even after access is revoked.