Improper Authentication Affecting org.apache.qpid:qpid-broker-plugins-amqp-0-8-protocol package, versions [6.0.0,6.0.2]


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEQPID-30711

  • published

    30 May 2016

  • disclosed

    30 May 2016

  • credit

    Unknown

How to fix?

Upgrade org.apache.qpid:qpid-broker-plugins-amqp-0-8-protocol to version or higher.

Overview

org.apache.qpid:qpid-broker-plugins-amqp-0-8-protocol is an AMQP 0-8, 0-9 and 0-9-1 protocol broker plug-in.

Affected versions of this package are vulnerable to Improper Authentication. The AMQP 0-8, 0-9, 0-91, and 0-10 connection handling in Apache Qpid Java before 6.0.3 might allow remote attackers to bypass authentication and consequently perform actions via vectors related to connection state logging.