Improper Authentication Affecting org.apache.qpid:qpid-common package, versions [,0.24)


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEQPID-472756

  • published

    10 Oct 2019

  • disclosed

    10 Oct 2019

  • credit

    Unknown

How to fix?

Upgrade org.apache.qpid:qpid-common to version 0.24 or higher.

Overview

org.apache.qpid:qpid-common is a Common functionality qpid package from Apache.

Affected versions of this package are vulnerable to Improper Authentication. The default configuration for Apache Qpid 0.20 and earlier, when the federation_tag attribute is enabled, accepts AMQP connections without checking the source user ID, which allows remote attackers to bypass authentication and have other unspecified impact via an AMQP request.

References