Access Restriction Bypass Affecting org.apache.ranger:ranger package, versions [,0.5.1)


0.0
medium

Snyk CVSS

    Attack Complexity Low
    Integrity High
Expand this section
NVD
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGAPACHERANGER-31471
  • published 31 Aug 2017
  • disclosed 5 Feb 2016
  • credit Unknown

How to fix?

Upgrade org.apache.ranger:ranger to version 0.5.1 or higher.

Overview

org.apache.ranger:ranger is a framework to enable, monitor and manage comprehensive data security across the Hadoop platform.

The Policy Admin Tool in Apache Ranger before 0.5.1 allows remote authenticated users to bypass intended access restrictions via the REST API.