SQL Injection Affecting org.apache.ranger:ranger Open this link in a new tab package, versions [,0.5.3)


0.0
high
  • Attack Complexity

    Low

  • Privileges Required

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHERANGER-31472

  • published

    31 Aug 2017

  • disclosed

    12 Apr 2016

  • credit

    Unknown

How to fix?

Upgrade org.apache.ranger:ranger to version 0.5.3 or higher.

Overview

org.apache.ranger:ranger is a framework to enable, monitor and manage comprehensive data security across the Hadoop platform.

SQL injection vulnerability in the policy admin tool in Apache Ranger before 0.5.3 allows remote authenticated administrators to execute arbitrary SQL commands via the eventTime parameter to service/plugins/policies/eventTime.