Access Restriction Bypass Affecting org.apache.ranger:ranger-hive-utils package, versions [,0.7.1)


0.0
medium
  • Attack Complexity

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHERANGER-31476

  • published

    31 Aug 2017

  • disclosed

    6 Jun 2017

  • credit

    Unknown

How to fix?

Upgrade org.apache.ranger:ranger-hive-utils to version 0.7.1 or higher.

Overview

org.apache.ranger:ranger-hive-utils is a framework to enable, monitor and manage comprehensive data security across the Hadoop platform.

Affected versions of the package are vulnerable to Access Restriction Bypass. In environments that use external location for hive tables, Hive Authorizer in Apache Ranger before 0.7.1 should be checking RWX permission for create table.