Interpretation Conflict Affecting org.apache.shiro:shiro-spring-boot-starter package, versions [,1.11.0)


0.0
medium

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGAPACHESHIRO-3244402
  • published 22 Jan 2023
  • disclosed 14 Jan 2023
  • credit v3ged0ge, Adamytd

How to fix?

Upgrade org.apache.shiro:shiro-spring-boot-starter to version 1.11.0 or higher.

Overview

Affected versions of this package are vulnerable to Interpretation Conflict via a specially crafted HTTP request. The root cause for this vulnerability is that Shiro and Spring Boot use different pattern-matching techniques. Exploiting this vulnerability might cause an authentication bypass.

NOTE: This vulnerability is relevant only when using Apache Shiro before 1.11.0, together with Spring Boot 2.6 +.

Mitigation

If upgrading to the fixed version is impossible, set the following Spring Boot configuration value: spring.mvc.pathmatch.matching-strategy = ant_path_matcher