Cryptographic Issues Affecting org.apache.shiro:shiro-crypto-cipher package, versions [,1.4.2)


0.0
low
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHESHIRO-534886

  • published

    19 Nov 2019

  • disclosed

    18 Nov 2019

  • credit

    Unknown

How to fix?

Upgrade org.apache.shiro:shiro-crypto-cipher to version 1.4.2 or higher.

Overview

org.apache.shiro:shiro-crypto-cipher is a cipher component for Apache Shiro security framework.

Affected versions of this package are vulnerable to Cryptographic Issues. When using the default "remember me" configuration, cookies are susceptible to a padding attack.