SQL Injection Affecting org.apache.skywalking:storage-jdbc-hikaricp-plugin package, versions [,8.1.0)


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHESKYWALKING-597399

  • published

    5 Aug 2020

  • disclosed

    5 Aug 2020

  • credit

    Unknown

How to fix?

Upgrade org.apache.skywalking:storage-jdbc-hikaricp-plugin to version 8.1.0 or higher.

Overview

org.apache.skywalking:storage-jdbc-hikaricp-plugin is a Storage JDBC HikariCP Plugin.

Affected versions of this package are vulnerable to SQL Injection. When using H2/MySQL/TiDB as Apache SkyWalking storage, there is a SQL injection vulnerability in the wildcard query cases.

References