Server-side Request Forgery (SSRF) Affecting org.apache.solr:solr-core Open this link in a new tab package, versions [1.3.0,7.6.0)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHESOLR-173769

  • published

    10 Mar 2019

  • disclosed

    8 Mar 2019

  • credit

    dk from Chaitin Tech

How to fix?

Upgrade org.apache.solr:solr-core to version 7.6.0 or higher.

Overview

org.apache.solr:solr-core is an open source enterprise search platform built on Apache Lucene

Affected versions of this package are vulnerable to Server-side Request Forgery (SSRF). The shards parameter does not have a corresponding whitelist mechanism, a remote attacker with access to the server could make Solr perform an HTTP GET request to any reachable URL.