Arbitrary Code Execution Affecting org.apache.storm:storm Open this link in a new tab package, versions [1.0.0,1.0.4) [1.1.0,1.1.1)


0.0
high
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHESTORM-31460

  • published

    31 Aug 2017

  • disclosed

    8 Aug 2017

  • credit

    Apche Storm PMC

How to fix?

Upgrade org.apache.storm:storm to version 1.0.4, 1.1.1 or higher.

Overview

org.apache.storm:storm is a free and open source distributed realtime computation system.

Affected versions of the package are vulnerable to Arbitrary Code Execution. It was found that under some situations and configurations of Apache Storm 1.x before 1.0.4 and 1.1.x before 1.1.1, it is theoretically possible for the owner of a topology to trick the supervisor to launch a worker as a different, non-root, user. In the worst case this could lead to secure credentials of the other user being compromised.