Remote Code Execution Affecting org.apache.struts:struts2-core package, versions [2.3.0, 2.3.35) [2.5.0, 2.5.17)


0.0
high
  • Exploit Maturity

    Mature

  • Attack Complexity

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHESTRUTS-32477

  • published

    22 Aug 2018

  • disclosed

    17 Aug 2018

  • credit

    Man Yue Mo

How to fix?

Upgrade org.apache.struts:struts2-core to version 2.3.35, 2.5.17 or higher.

Overview

org.apache.struts:struts2-core is a popular open-source framework for developing web applications in the Java programming language.

Affected versions of this package are vulnerable to Remote Code Execution. When the namespace value is not set for a result defined in underlying xml configurations, and in same time, its upper action(s) configurations have no or wildcard namespace, an attacker may be able to conduct a remote code execution attack. They could also use the opportunity when using a url tag which does not have a value and action set and in same time, its upper action(s) configurations have no or wildcard namespace.