Arbitrary Code Execution Affecting org.apache.struts.xwork:xwork-core package, versions [2.1.0, 2.3.1.1)


0.0
medium
0
10

Snyk CVSS

    Attack Complexity Low
    User Interaction Required

    Threat Intelligence

    Exploit Maturity Mature
    EPSS 93.79% (100th percentile)
Expand this section
NVD
6.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGAPACHESTRUTSXWORK-30791
  • published 17 Jun 2014
  • disclosed 8 Jan 2012
  • credit Unknown

How to fix?

Upgrade org.apache.struts.xwork:xwork-core to version 2.3.1.1 or higher.

Overview

org.apache.struts.xwork:xwork-core is a generic command pattern framework. It forms the core of Struts 2.

Affected versions of this package are vulnerable to Arbitrary Code Execution. ** DISPUTED ** The DebuggingInterceptor component in Apache Struts before 2.3.1.1, when developer mode is used, allows remote attackers to execute arbitrary commands via unspecified vectors. NOTE: the vendor characterizes this behavior as not "a security vulnerability itself."