Information Exposure Affecting org.apache.syncope:syncope-core Open this link in a new tab package, versions [1.2.0, 1.2.11) [2.0.0, 2.0.8)


0.0
medium
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

  • Privileges Required

    High

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHESYNCOPE-32139

  • published

    21 Mar 2018

  • disclosed

    20 Mar 2018

  • credit

    Unknown

Overview

org.apache.syncope:syncope-core is an Open Source system for managing digital identities in enterprise environments, implemented in Java EE technology and released under Apache 2.0 license.

Affected versions of this package are vulnerable to Information Exposure. An administrator with user search entitlements can recover sensitive security values using the fiql and orderby parameters.

Remediation

Upgrade org.apache.syncope:syncope-core to versions 1.2.11, 2.0.8 or higher.