Improper Access Control Affecting org.apache.thrift:libthrift package, versions [0.9.2, 0.11.0)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHETHRIFT-173706

  • published

    17 Feb 2019

  • disclosed

    7 Jan 2019

  • credit

    Asger Feldthaus

How to fix?

Upgrade org.apache.thrift:libthrift to version 0.11.0 or higher.

Overview

org.apache.thrift:libthrift is a lightweight, language-independent software stack with an associated code generation mechanism for point-to-point RPC.

Affected versions of this package are vulnerable to Improper Access Control. A remote user had the ability to access files outside the set webservers docroot path.