Information Exposure Affecting org.apache.tomcat:coyote Open this link in a new tab package, versions [6.0.30,6.0.34)
Do your applications use this vulnerable package?
In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.Test your applications
10 Jun 2015
19 Jan 2012
How to fix?
org.apache.tomcat:coyote to version 6.0.34 or higher.
org.apache.tomcat:coyote is a maven plugin for Tomcat Connectors and HTTP parser.
Affected versions of this package are vulnerable to Information Exposure. Apache Tomcat 6.0.30 through 6.0.33 and 7.x before 7.0.22 does not properly perform certain caching and recycling operations involving request objects, which allows remote attackers to obtain unintended read access to IP address and HTTP header information in opportunistic circumstances by reading TCP data.