Access Restriction Bypass Affecting org.apache.tomcat:tomcat-catalina package, versions [7.0.12, 7.0.14)


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required

    Threat Intelligence

    EPSS 0.23% (60th percentile)
Expand this section
NVD
5.4 medium
Expand this section
Red Hat
5.4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGAPACHETOMCAT-30886
  • published 10 Jun 2015
  • disclosed 8 Apr 2011
  • credit Unknown

How to fix?

Upgrade org.apache.tomcat:tomcat-catalina to version 7.0.14 or higher.

Overview

org.apache.tomcat:tomcat-catalina is a Tomcat Servlet Engine Core Classes and Standard implementations.

Affected versions of this package are vulnerable to Access Restriction Bypass. When web.xml has no login configuration, does not follow security constraints, which allows remote attackers to bypass intended access restrictions via HTTP requests to a meta-data complete web application.

NOTE: this vulnerability exists because of an incorrect fix for CVE-2011-1088 and CVE-2011-1419.

References