Information Exposure Affecting org.apache.tomcat:tomcat-catalina package, versions [7.0.0,7.0.40)


0.0
low
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHETOMCAT-30907

  • published

    8 Jun 2014

  • disclosed

    1 Jun 2013

  • credit

    Unknown

Overview

org.apache.tomcat:tomcat-catalina java/org/apache/catalina/core/AsyncContextImpl.java in Apache Tomcat 7.x before 7.0.40 does not properly handle the throwing of a RuntimeException in an AsyncListener in an application, which allows context-dependent attackers to obtain sensitive request information intended for other applications in opportunistic circumstances via an application that records the requests that it processes.

References