Improper Access Control Affecting org.apache.tomcat:tomcat-el-api package, versions [7,7.0.58) [8,8.0.16)


0.0
medium

Snyk CVSS

    Attack Complexity Low
NVD  medium
RHEL  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGAPACHETOMCAT-30939
  • published 14 May 2015
  • disclosed 14 May 2015
  • credit Unknown

How to fix?

Upgrade org.apache.tomcat:tomcat-el-api to version 7.0.58, 8.0.16 or higher.

Overview

org.apache.tomcat:tomcat-el-api is an Expression language package for Tomcat.

Affected versions of this package are vulnerable to Improper Access Control. It does not properly consider the possibility of an accessible interface implemented by an inaccessible class, which allows attackers to bypass a SecurityManager protection mechanism via a web application that leverages use of incorrect privileges during EL evaluation.

References