Arbitrary File Read Affecting org.apache.tomcat:tomcat-jasper Open this link in a new tab package, versions [7.0.0,7.0.54) [8,8.0.6)


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHETOMCAT-30941

  • published

    8 Sep 2014

  • disclosed

    31 May 2014

  • credit

    Unknown

How to fix?

Upgrade org.apache.tomcat:tomcat-jasper to version 7.0.54, 8.0.6 or higher.

Overview

org.apache.tomcat:tomcat-jasper is a Tomcats JSP Parser

Affected versions of this package are vulnerable to Arbitrary File Read. Apache Tomcat before 6.0.40, 7.x before 7.0.54, and 8.x before 8.0.6 does not properly constrain the class loader that accesses the XML parser used with an XSLT stylesheet, which allows remote attackers to (1) read arbitrary files via a crafted web application that provides an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue, or (2) read files associated with different web applications on a single Tomcat instance via a crafted web application.