Arbitrary Code Execution Affecting org.apache.tomcat:tomcat-util Open this link in a new tab package, versions [,7.0.82) [8,8.0.46) [8.5,8.5.22) [9.0.0.M1, 9.0.1)
Do your applications use this vulnerable package?
In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.Test your applications
11 Oct 2017
21 Sep 2017
How to fix?
org.apache.tomcat:tomcat-util to version 7.0.82, 8.0.46, 8.5.22, 9.0.1 or higher.
org.apache.tomcat:tomcat-util is a Common code shared by multiple Tomcat components.
Affected versions of this package are vulnerable to Arbitrary Code Execution. When running Apache Tomcat versions 9.0.0.M1 to 9.0.0, 8.5.0 to 8.5.22, 8.0.0.RC1 to 8.0.46 and 7.0.0 to 7.0.81 with HTTP PUTs enabled (e.g. via setting the readonly initialisation parameter of the Default servlet to false) it was possible to upload a JSP file to the server via a specially crafted request. This JSP could then be requested and any code it contained would be executed by the server.
This is due to an incomplete fix for CVE-2017-12615.