Arbitrary File Upload Affecting org.apache.tomcat:tomcat-util package, versions [7.0.0, 7.0.40)


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHETOMCAT-451607

  • published

    25 Dec 2016

  • disclosed

    19 Jan 2014

  • credit

    Unknown

How to fix?

Upgrade org.apache.tomcat:tomcat-util to version 7.0.40 or higher.

Overview

org.apache.tomcat:tomcat-util is a Common code shared by multiple Tomcat components.

Affected versions of this package are vulnerable to Arbitrary File Upload in certain situations involving outdated java.io.File code and a custom JMX configuration, allows remote attackers to execute arbitrary code by uploading and accessing a JSP file.