Information Exposure Affecting org.apache.tomcat:catalina package, versions [6.0.0, 6.0.20)


0.0
medium

Snyk CVSS

    Attack Complexity Low
    Privileges Required High

    Threat Intelligence

    EPSS 0.05% (15th percentile)
Expand this section
NVD
4.2 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGAPACHETOMCAT-468852
  • published 22 Sep 2019
  • disclosed 5 Jun 2009
  • credit Tomcat Security Team

How to fix?

Upgrade org.apache.tomcat:catalina to version 6.0.20 or higher.

Overview

org.apache.tomcat:catalina is a Servlet Engine Core Classes and Standard implementations.

Affected versions of this package are vulnerable to Information Exposure. It permits web applications to replace an XML parser used for other web applications, which allows local users to read or modify the web.xml, context.xml, or tld files of arbitrary web applications via a crafted application that is loaded earlier than the target application.