Untrusted Object Deserialization Affecting org.apache.tomee:arquillian-tomee-common Open this link in a new tab package, versions [7-alpha,7.0.0-M3)


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHETOMEE-30995

  • published

    15 Mar 2016

  • disclosed

    15 Mar 2016

  • credit

    Romain Manni-Bucau

Overview

org.apache.tomee:arquillian-tomee-common Affected versions of the package are vulnerable to Untrusted Object Deserialization. The EjbObjectInputStream class in Apache TomEE before 1.7.4 and 7.x before 7.0.0-M3 allows remote attackers to execute arbitrary code via a crafted serialized object.