Improper Output Neutralization for Logs Affecting org.apache.unomi:unomi-plugins-base package, versions [,1.5.5)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEUNOMI-1279035

  • published

    4 May 2021

  • disclosed

    4 May 2021

  • credit

    Unknown

How to fix?

Upgrade org.apache.unomi:unomi-plugins-base to version 1.5.5 or higher.

Overview

org.apache.unomi:unomi-plugins-base is an It stores user profile information and is mostly used to provide a backend server for A/B testing and personalization.

Affected versions of this package are vulnerable to Improper Output Neutralization for Logs. Allows CRLF log injection because of the lack of escaping in the log statements.