Improper Authentication Affecting org.apache.wss4j:wss4j-ws-security-dom package, versions [2.0.0,2.0.2)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPACHEWSS4J-31028

  • published

    25 Dec 2016

  • disclosed

    25 Oct 2014

  • credit

    Dario Amiri

How to fix?

Upgrade org.apache.wss4j:wss4j-ws-security-dom to version 2.0.2 or higher.

Overview

org.apache.wss4j:wss4j-ws-security-dom is a Web Services Security (WS-Security) library being developed at OASIS Web Services Security TC. WSS4J is a primarily a Java library that can be used to sign and verify SOAP Messages with WS-Security information. WSS4J will use Apache Axis and Apache XML-Security projects and will be interoperable with JAX-RPC based server/clients and .NET server/clients.

Affected versions of this package are vulnerable to Improper Authentication. When using TransportBinding, does not properly enforce the SAML SubjectConfirmation method security semantics, which allows remote attackers to conduct spoofing attacks via unspecified vectors.