Access Control Bypass Affecting org.apache.zookeeper:zookeeper package, versions [,3.4.14) [3.5.0-alpha, 3.5.5)


0.0
medium

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
Expand this section
NVD
5.9 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGAPACHEZOOKEEPER-174781
  • published 23 May 2019
  • disclosed 23 May 2019
  • credit Harrison Neal

How to fix?

Upgrade org.apache.zookeeper:zookeeper to version 3.4.14, 3.5.5 or higher.

Overview

org.apache.zookeeper:zookeeper is a centralized service for maintaining configuration information, naming, providing distributed synchronization, and providing group services.

Affected versions of this package are vulnerable to Access Control Bypass. ZooKeeper’s getACL() method doesn’t check any permission when retrieving the ACLs of the requested node and returns all information contained in the ACL Id field as plain text string. If Digest Authentication is in use, the unsalted hash value will be disclosed by the getACL() method for unauthenticated or unprivileged users.