Insecure Randomness Affecting org.apereo.cas:cas-server-support-oauth-core-api Open this link in a new tab package, versions [,6.1.0-RC5)


0.0
high
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGAPEREOCAS-467406

  • published

    20 Sep 2019

  • disclosed

    20 Sep 2019

  • credit

    Jonathan Leitschuh

How to fix?

Upgrade org.apereo.cas:cas-server-support-oauth-core-api to version 6.1.0-RC5 or higher.

Overview

org.apereo.cas:cas-server-support-oauth-core-api is a CAS Server Support OAuth Core API for supporting OAuth within Apereo CAS.

Affected versions of this package are vulnerable to Insecure Randomness. A insecure source of randomness is used to generate all of its random values as it relies upon apache commons lang3 RandomStringUtils. This could allow an attacker to possibly generate their own unique Ticket ID due to insufficient randomness.