Insufficient Validation Affecting org.bouncycastle:bcprov-jdk15on package, versions [,1.56)


0.0
high
  • Attack Complexity

    Low

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGBOUNCYCASTLE-32340

  • published

    3 Jun 2018

  • disclosed

    15 Oct 2016

  • credit

    Unknown

How to fix?

Upgrade org.bouncycastle:bcprov-jdk15on to version 1.56 or higher.

Overview

org.bouncycastle:bcprov-jdk15on is a Java implementation of cryptographic algorithms.

Affected versions of this package are vulnerable to Insufficient Validation. The DSA does not fully validate ASN.1 encoding of signature on verification. It is possible to inject extra elements in the sequence making up the signature and still have it validate, which in some cases may allow the introduction of invisible data into a signed structure.

References