Improper Authentication Affecting org.cloudfoundry.identity:cloudfoundry-identity-login package, versions [,2.5.2)


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGCLOUDFOUNDRYIDENTITY-31058
  • published 28 Sep 2016
  • disclosed 28 Sep 2016
  • credit Unknown

Overview

org.cloudfoundry.identity:cloudfoundry-identity-login Affected versions of the package are vulnerable to Improper Authentication which occurs due to the Password Reset Link not expiring.

Note: Deployments enabled for integration via SAML or LDAP are not affected.