Session Fixation Affecting org.cloudfoundry.identity:cloudfoundry-identity-common package, versions [,2.7.4.13)


0.0
high

Snyk CVSS

    Attack Complexity High
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.22% (60th percentile)
Expand this section
NVD
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGCLOUDFOUNDRYIDENTITY-31413
  • published 21 May 2017
  • disclosed 31 Mar 2017
  • credit GE Digital Security Team

How to fix?

Upgrade org.cloudfoundry.identity:cloudfoundry-identity-common to version 2.7.4.13 or higher.

Overview

org.cloudfoundry.identity:cloudfoundry-identity-common is a CloudFoundry Identity Common package.

Affected versions of this package are vulnerable to Session Fixation, via the User Account and Authentication (UAA). When UAA is configured to authenticate against external SAML or OpenID Connect based identity providers.