HTTP Headers Forwarding Affecting org.cloudfoundry.identity:cloudfoundry-identity-uaa Open this link in a new tab package, versions [3.0.0,3.6.12) [3.7,3.9.14) [3.10.0,3.19.0)


0.0
high
  • Attack Complexity

    Low

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGCLOUDFOUNDRYIDENTITY-32146

  • published

    1 Apr 2018

  • disclosed

    13 Jun 2017

  • credit

    Unknown

How to fix?

Upgrade org.cloudfoundry.identity:cloudfoundry-identity-uaa to version 3.19.0, 3.9.14, 3.6.12 or higher.

Overview

org.cloudfoundry.identity:cloudfoundry-identity-uaa is a CloudFoundry User Account and Authentication (UAA) Server.

Affected version of this package are vulnerable to HTTP Headers Forwarding, which could result in account corruption.