Improper Privileges Affecting org.cloudfoundry.identity:cloudfoundry-identity-uaa Open this link in a new tab package, versions [2.0.0,2.7.4.16) [3.6.0,3.6.10) [3.9.0,3.9.12) [3.10.0,3.17.0)


0.0
high
  • Attack Complexity

    Low

  • Privileges Required

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGCLOUDFOUNDRYIDENTITY-32148

  • published

    1 Apr 2018

  • disclosed

    13 Jun 2017

  • credit

    Unknown

How to fix?

Upgrade org.cloudfoundry.identity:cloudfoundry-identity-uaa to version 2.7.4.16, 3.6.10, 3.9.12, 3.17.0 or higher.

Overview

org.cloudfoundry.identity:cloudfoundry-identity-uaa is a CloudFoundry User Account and Authentication (UAA) Server.

Affected versions of this package are vulnerable to Improper Privileges. Privileged users in one zone are allowed to perform a password reset for users in a different zone.