Insecure Permissions Affecting org.csanchez.jenkins.plugins:kubernetes package, versions [,1.27.4)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGCSANCHEZJENKINSPLUGINS-1037274

  • published

    5 Nov 2020

  • disclosed

    5 Nov 2020

  • credit

    Unknown

How to fix?

Upgrade org.csanchez.jenkins.plugins:kubernetes to version 1.27.4 or higher.

Overview

Affected versions of this package are vulnerable to Insecure Permissions. Kubernetes Plugin 1.27.3 and earlier does not perform a permission check in an HTTP endpoint. This allows attackers with Overall/Read permission to list global pod template names.Kubernetes Plugin 1.27.4 requires Overall/Administer permission to list global pod template names.