Information Exposure Affecting org.csanchez.jenkins.plugins:kubernetes Open this link in a new tab package, versions [,1.27.4)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGCSANCHEZJENKINSPLUGINS-1037275

  • published

    5 Nov 2020

  • disclosed

    5 Nov 2020

  • credit

    Unknown

How to fix?

Upgrade org.csanchez.jenkins.plugins:kubernetes to version 1.27.4 or higher.

Overview

Affected versions of this package are vulnerable to Information Exposure. Kubernetes Plugin 1.27.3 and earlier includes a feature to replace placeholders in pod template and container template fields with environment variable values.This feature allows low-privilege users to access possibly sensitive Jenkins controller environment variables.