Incorrect Authorization Affecting org.dspace:dspace-api package, versions [7.0,7.1)


0.0
high
  • Attack Complexity

    Low

  • Privileges Required

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGDSPACE-1769213

  • published

    31 Oct 2021

  • disclosed

    31 Oct 2021

  • credit

    Unknown

How to fix?

Upgrade org.dspace:dspace-api to version 7.1 or higher.

Overview

org.dspace:dspace-api is a DSpace core data model and service APIs.

Affected versions of this package are vulnerable to Incorrect Authorization. Any community or collection administrator can escalate their permission up to become system administrator.