Information Exposure Affecting org.eclipse.jetty:jetty-deploy Open this link in a new tab package, versions [9.4.32,9.4.39) [10.0.0.beta2,10.0.2) [11.0.0.beta2, 11.0.2)


0.0
low
  • Attack Complexity

    Low

  • Privileges Required

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGECLIPSEJETTY-1090338

  • published

    2 Apr 2021

  • disclosed

    2 Apr 2021

  • credit

    Unknown

How to fix?

Upgrade org.eclipse.jetty:jetty-deploy to version 9.4.39, 10.0.2, 11.0.2 or higher.

Overview

Affected versions of this package are vulnerable to Information Exposure. If a user uses a webapps directory that is a symlink, the contents of the webapps directory is deployed as a static webapp, inadvertently serving the webapps themselves and anything else that might be in that directory.