Information Disclosure Affecting org.elasticsearch:elasticsearch package, versions [7.0.0, 7.11.2) [,6.8.15)


0.0
low
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGELASTICSEARCH-1089258

  • published

    26 Mar 2021

  • disclosed

    23 Mar 2021

  • credit

    Unknown

How to fix?

Upgrade org.elasticsearch:elasticsearch to version 7.11.2, 6.8.15 or higher.

Overview

org.elasticsearch:elasticsearch is a Distributed, RESTful Search Engine.

Affected versions of this package are vulnerable to Information Disclosure. A document disclosure flaw was found in Elasticsearch when Document or Field Level Security is used. Search queries do not properly preserve security permissions when executing certain cross-cluster search queries. This could result in the search disclosing the existence of documents the attacker should not be able to view. This could result in an attacker gaining additional insight into potentially sensitive indices.