Information Disclosure Affecting org.elasticsearch:elasticsearch package, versions [7.0.0, 7.11.2) [,6.8.15)


0.0
low
  • Attack Complexity

    High

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGELASTICSEARCH-1089259

  • published

    26 Mar 2021

  • disclosed

    23 Mar 2021

  • credit

    Unknown

How to fix?

Upgrade org.elasticsearch:elasticsearch to version 7.11.2, 6.8.15 or higher.

Overview

org.elasticsearch:elasticsearch is a Distributed, RESTful Search Engine.

Affected versions of this package are vulnerable to Information Disclosure. A document disclosure flaw was found in the Elasticsearch suggester and profile API when Document and Field Level Security are enabled. The suggester and profile API are normally disabled for an index when document level security is enabled on the index. Certain queries are able to enable the profiler and suggester which could lead to disclosing the existence of documents and fields the attacker should not be able to view.