Arbitrary Code Execution Affecting org.elasticsearch:elasticsearch package, versions [,1.6.0)


0.0
high
  • Attack Complexity

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGELASTICSEARCH-31129

  • published

    10 Jun 2015

  • disclosed

    10 Jun 2015

  • credit

    Unknown

How to fix?

Upgrade org.elasticsearch:elasticsearch to version 1.6.0 or higher.

Overview

org.elasticsearch:elasticsearch is a Distributed, RESTful Search Engine.

Affected versions of this package are vulnerable to Arbitrary Code Execution. The snapshot API may be used indirectly to place snapshot metadata files into locations that are writeable by the user running the Elasticsearch process. It is possible to create a file that another application could read and take action on, resulting in code execution.