Remote Code Execution (RCE) Affecting org.esigate:esigate-core Open this link in a new tab package, versions [,5.3)


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGESIGATE-451683

  • published

    23 Jul 2019

  • disclosed

    20 Dec 2018

  • credit

    Unknown

How to fix?

Upgrade org.esigate:esigate-core to version 5.3 or higher.

Overview

org.esigate:esigate-core is a Webapp integration, Remote templating, Web accelerator.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). A remote attacker could execute code on the server with a user specified XSLT due to the support of ESIGate in esi:include tag along with stylesheet attribute.