Man-in-the-Middle (MitM) Affecting org.grails:grails-core Open this link in a new tab package, versions [,3.3.10)


0.0
high
  • Attack Complexity

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGGRAILS-174899

  • published

    4 Jun 2019

  • disclosed

    4 Jun 2019

  • credit

    Jonathan Leitschuh

How to fix?

Upgrade org.grails:grails-core to version 3.3.10 or higher.

Overview

org.grails:grails-core is a framework used to build web applications with the Groovy programming language. The core framework is very extensible and there are numerous plugins available that provide easy integration of add-on features.

Affected versions of this package are vulnerable to Man-in-the-Middle (MitM). Cleartext HTTP protocol is used within specific versions of Grails core to resolve the SDKMan notification service. It should be noted that dependencies were not resolved or fetched over cleartext HTTP. As such, success exploitation of this vulnerability is low.