Information Exposure Affecting org.grails:grails-resources Open this link in a new tab package, versions [2.0.0,2.3.7)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGGRAILS-30097

  • published

    25 Dec 2016

  • disclosed

    15 Apr 2014

  • credit

    Unknown

How to fix?

Upgrade org.grails:grails-resources to version 2.3.7 or higher.

Overview

org.grails:grails-resources is a resources plugin for Grails.

Affected versions of this package are vulnerable to Information Exposure. The default configuration of the Resources plugin 1.0.0 before 1.2.6 for Pivotal Grails 2.0.0 before 2.3.6 does not properly restrict access to files in the WEB-INF directory, which allows remote attackers to obtain sensitive information via a direct request.

NOTE: this identifier has been SPLIT due to different researchers and different vulnerability types. See CVE-2014-2857 for the META-INF variant and CVE-2014-2858 for the directory traversal.