Cross-site Request Forgery (CSRF) Affecting org.hswebframework.web:hsweb-system-oauth2-client-web Open this link in a new tab package, versions [,3.0.5)


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGHSWEBFRAMEWORKWEB-73566

  • published

    30 Dec 2018

  • disclosed

    30 Dec 2018

  • credit

    Unknown

How to fix?

Upgrade org.hswebframework.web:hsweb-system-oauth2-client-web to version 3.0.5 or higher.

Overview

org.hswebframework.web:hsweb-system-oauth2-client-web is a basic project for quickly setting up an enterprise back-end management system.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) due to a lack of a comparison between the state parameter in the request and the state parameter in the session after user authentication is successful.