Unsigned to Signed Conversion Error Affecting org.hyperledger.besu:evm package, versions [22.4.0-RC1,22.7.1)


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Integrity High
    Availability High
Expand this section
NVD
9.1 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JAVA-ORGHYPERLEDGERBESU-3032991
  • published 25 Sep 2022
  • disclosed 23 Sep 2022
  • credit Martin Holst Swende

How to fix?

Upgrade org.hyperledger.besu:evm to version 22.7.1 or higher.

Overview

Affected versions of this package are vulnerable to Unsigned to Signed Conversion Error due to a gas allocation error in CALL operations, which may result in a consensus failure in networks with multiple EVM implementations

References