Insecure Authentication Affecting org.infinispan:infinispan-compatibility-mode-it package, versions [,9.0.0.CR3)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGINFINISPAN-32418

  • published

    19 Jul 2018

  • disclosed

    3 Mar 2017

  • credit

    Unknown

How to fix?

Upgrade org.infinispan:infinispan-compatibility-mode-it to version 9.0.0 or higher.

Overview

org.infinispan:infinispan-compatibility-mode-it is an open source data grid platform and highly scalable NoSQL cloud data store.

Affected versions of this package are vulnerable to Insecure Authentication. It did not properly enforce auth constraints. An attacker could use this vulnerability to read or modify data in the default cache or a known cache name.