URL Parameter Injection Affecting org.jasig.cas:cas-client-core package, versions [,3.3.2)


0.0
low
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGJASIGCAS-30104

  • published

    25 Dec 2016

  • disclosed

    25 Dec 2016

  • credit

    Unknown

How to fix?

Upgrade org.jasig.cas:cas-client-core to version 3.3.2 or higher.

Overview

org.jasig.cas:cas-client-core is a Java CAS client.

Affected versions of this package are vulnerable to URL Parameter Injection. It was found that URL encoding used in the back-channel ticket validation of the JA-SIG CAS client was improper. A remote attacker could exploit this flaw to bypass security constraints by injecting URL parameters