Information Exposure Affecting org.jboss.resteasy:resteasy-jaxrs Open this link in a new tab package, versions [,3.1.0.CR1)


0.0
medium
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGJBOSSRESTEASY-31203

  • published

    5 Sep 2016

  • disclosed

    5 Sep 2016

  • credit

    Mikhail Egorov

How to fix?

Upgrade org.jboss.resteasy:resteasy-jaxrs to version 3.1.0.CR1 or higher.

Overview

org.jboss.resteasy:resteasy-jaxrs is a JCP specification that provides a Java API for RESTful Web Services over the HTTP protocol.

Affected versions of this package are vulnerable to Information Exposure. It allows remote authenticated users to obtain sensitive information by leveraging insufficient use of random values in async jobs.

References