Arbitrary Code Injection Affecting org.jboss.seam:jboss-seam Open this link in a new tab package, versions [0,]


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGJBOSSSEAM-30122

  • published

    25 Dec 2016

  • disclosed

    7 Jul 2014

  • credit

    Marek Schmidt

How to fix?

There is no fixed version for org.jboss.seam:jboss-seam.

Overview

org.jboss.seam:jboss-seam is a Seam core module for Seam framework integrated with JSF2

Affected versions of this package are vulnerable to Arbitrary Code Injection. org.jboss.seam.web.AuthenticationFilter class allows remote attackers to execute arbitrary code via a crafted authentication header, related to Seam logging.