Improper Authorization Affecting org.jenkins-ci.plugins:deployer-framework package, versions [0,]


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JAVA-ORGJENKINSCIPLUGINS-2964196

  • published

    31 Jul 2022

  • disclosed

    31 Jul 2022

  • credit

    Unknown

How to fix?

A fix was pushed into the master branch but not yet published.

Overview

Affected versions of this package are vulnerable to Improper Authorization due to missing restricting of the name of files in methods implementing form validation, allowing attackers with Item/Read permission to check for the existence of an attacker-specified file path on the Jenkins controller file system.